Donnez vie à vos documents numériques !
 

Vérifier la version du Reader à l’ouverture d’un document.

abracadabraPDF Forums PDF – Général Vérifier la version du Reader à l’ouverture d’un document.

  • Ce sujet est vide.
  • Créateur
    Sujet
  • #43667
    Lionel
    Membre

    Bonjour,

    Désormais, les récentes versions du Reader vérifient -si une connexion internet est active- s’il existe une version supérieure du Reader que celle en service actuellement sur votre configuration. Puis propose de la télécharger.

    Ma question est de savoir, si on pouvait intégrer dans un document PDF un script qui lancerai le même type de vérification (script lancé à l’ouverture d’un document) et de proposition de mise à jour. Je pense que connaître la version utilisée du Reader c’est simple, après, pour l’info de la version la plus récente c’est là que ça se complique (car ensuite comparer deux chiffres et déclencher ceci, c’est à mon avis facilement faisable).

    Le but est d’informer / d’inciter à mettre à jour les encore nombreuses personnes qui possèdent encore des versions 4 ou 5 du Reader; j’en connais plein. Et, pour cela, une procédure automatique serait bien.

    Bien cordialement. :bonjour:
    Lionel

Affichage de 4 réponses de 26 à 29 (sur un total de 29)
  • Auteur
    Réponses
  • #49877
    Lionel
    Membre

    Bonjour,

    Bof, bof.
    J’en connais qui impriment systématiquement tout et cette page de garde serait du plus mauvais effet (à moins, et encore, de faire en sorte qu’elle ne s’imprime pas (ni qu’elle apparaissent dans les vignettes…). Bref, je préfère ma solution (un message qui s’affiche systématiquement, sauf si…).

    Bien cordialement.
    Lionel

    #49878
    Merlin
    Maître des clés

    De fait cela peut faire mauvais effet à l’impression, c’est pour ça que j’ai parlé de la technique de la pièce jointe.
    :extra:

    #49879
    Merlin
    Maître des clés

    A l’évidence je me suis trompé depuis le début, ça ce n’est pas bon :

    Code:
    if (app.viewerVariation == « Reader » && app.viewerVersion >= 7)

    Et ça c’est bon :

    Code:
    if (app.viewerVariation == « Reader » && app.viewerVersion

    Le n’était pas dans le bon sens…

    :siffle: :Ooops: :joker:

    #49880
    Lionel
    Membre

    Bonjour,

    Je l’ai rectifié dans le script original. Comme cela, si quelqu’un fait un copier / coller sans regarder la suite du sujet…

    Bien cordialement :bonjour:
    Lionel

  • Affichage de 4 réponses de 26 à 29 (sur un total de 29)
    • Vous devez être connecté pour répondre à ce sujet.