Donnez vie à vos documents numériques !
 

Répondre à : Compatibilité Acrobat 9 et versions précédentes

abracadabraPDF Forums PDF – Général Compatibilité Acrobat 9 et versions précédentes Répondre à : Compatibilité Acrobat 9 et versions précédentes

#50065
Merlin
Maître des clés

1) comment peut-on afficher ce message uniquement si la version est inférieure à Reader 9 (app.viewerVersion 2) comment l’alerte est assez grande et que je dois la faire en 3 langues (Français, Allemand et Anglais pour tous les autres pays) est-il possible de récupérer la langue de l’ordinateur et d’afficher l’alerte uniquement dans la langue du pays.

if (app.language == « FRA »)
{
var monalerte = « TEXTE EN FRANÇAIS »;
}
else if (app.language == « DEU »)
{
var monalerte = « TEXTE EN ALLEMAND »;
}
else
{
var monalerte = « TEXTE EN ANGLAIS »;
}

////////////////////
if  (typeof app.formsVersion != ‘undefined’ && app.formsVersion {
app.alert(monalerte, 3);
}

Sans oublier d’utiliser l’utilitaire Abra-Txt2Unicode pour éviter les erreurs d’affichage dans les messages :
http://abracadabrapdf.net/articles.php?lng=fr&pg=440

:RoiReine:

3) que faire si aucun reader n’est installé sur le poste de travail???

Ce doit être un cas assez rare, mais c’est une bonne question… je te remercie de l’avoir posée !

A part une bonne grosse étiquette sur le CD, je ne vois pas.

:joker: