Donnez vie à vos documents numériques !
 

Cacher un bouton radio parmi d’autres

abracadabraPDF Forums PDF – Général Cacher un bouton radio parmi d’autres

  • Ce sujet est vide.
  • Créateur
    Sujet
  • #45902
    Patakess
    Membre

    Bonjour c’est encore moi !
    Voilà, cette fois j’aimerais cacher un bouton radio, perdu donc au milieu d’autres boutons. Il a bien une valeur spécifique.
    Mais je n’arrive pas à ‘isoler’ ce bouton, je ne connais pas le code ^^ ».
    Pour afficher/Cacher j’utilise

    Code:
    var int4 = this.getField(« Livraison »);
    var int5 = this.getField(« Paiement »);
    if(int4.value== »2″ ){
      this.getField(« Espece »).display = display.hidden;
    } else {
      this.getField(« Espece »).display= display.visible;}

    La case à cocher est dans la variable Paiement et s’appelle Espèce. Je vois bien qu’il manque un truc, mais j’ai testé, je n’ai pas trouvé :( .

    Edit: J’ai essayé de faire la méthode ‘Je met un carré de la couleur du fond devant’ sauf que… Je n’arrive pas à changer l’ordre et il est derrière mon bouton ^^ »

    Merci d’avance !

Affichage de 10 réponses de 1 à 10 (sur un total de 10)
  • Auteur
    Réponses
  • #64392
    bebarth
    Maître des clés

    bonjour,
    j’ai copié/collé ton script et il fonctionne très bien !
    Par contre, je ne comprend pas :

    La case à cocher est dans la variable Paiement et s’appelle Espèce.

    @+
    :bonjour:

    #64393
    Patakess
    Membre

    Bonjour.

    Ah ben je viens d’éditer o/

    Le groupe de bouton s’appelle ‘Paiement’. Et dedans j’ai les boutons qui exportent les valeurs ‘cheques’ ‘Espece’ etc… J’aimerai que ce ne soit que le bouton ‘Espece’ qui disparaisse lorsque je clique sur un bouton spécifique (d’un autre groupe de bouton, livraisons, au dessus). 

    #64394
    Patakess
    Membre

    Du coup… Je ne sais pas comment faire toujours ^^ »

    #64395
    bebarth
    Maître des clés

    bonjour,
    …comme ça je ne vois pas comment faire « directement » !
    Si on compte le nombre de champ avec this.numFields; on en trouve que 2 (ce qui me parait logique pour des boutons radio), sauf que je ne sais pas comment masquer uniquement celui du milieu. Je ne dis pas que c’est impossible car on peut y arriver manuellement en mettant ce champ de formulaire invisible à l’écran. Mais via JavaScript, je n’ai pas de piste… sinon faire apparaitre un carré de même couleur que le fond, qui cacherait ce bouton…
    @+
    :bonjour:

    #64396
    Patakess
    Membre

    Arf damned.

    J’ai pensé à mettre un cache dessus oui, methode ‘mac gyver’. Mais je n’arrive pas à faire passer le cache ‘devant’. Il est derriere le bouton >

    #64397
    bebarth
    Maître des clés

    Je ne peux pas t’expliquer pourquoi (peut-être Merlin ???) mais apparemment la taille du cache doit être plus petite que la taille du champ du bouton (mais plus grande que le bouton… si on veut le cacher  :geek: ).
    @+
    :bonjour:

    #64398
    Merlin
    Maître des clés

    Le champ en tête de liste est en arrière-plan, le champ en fin de liste est en premier-plan.
    Il faut « Trier les onglets manuellement » pour modifier l’ordre automatique.

    #64399
    Patakess
    Membre

    Ca n’a aucune sens omg xD.

    AH ! Merci Merlin, j’étais partis…. Sur l’inverse en fait xD j’ai meme pas pensé que ca pouvait etre dans se sens là. Merci !

    #64400
    bebarth
    Maître des clés

    Merci Merlin,
    c’est bien ce que j’avais remarqué, mais comment est attribuée l’ordre ?
    Pourquoi lorsque l’on change la taille du champ du cache par exemple, sa position d’ordre est-elle systématiquement modifiée ?
    Donc plus on augmente son ordre de tabulation et plus le champ est en avant ? correct ? Le plus grand numéro d’ordre est don au premier plan ?
    …et le résultat n’est pas toujours ce qu’il devrait être apparemment !
    @+
    :bonjour:

    #64401
    Merlin
    Maître des clés

    C’est parce-qu’un grand malade mental a jugé bon de placer cette option (voir capture) dans les Préférences d’Acrobat Pro et de l’activer par défaut.
    Personnellement je l’ai désactivée pour ne pas devenir fou.
    :mur:

Affichage de 10 réponses de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.