Donnez vie à vos documents numériques !
 

Logo variable en fonction du choix dans liste déroulante (2) – RÉSOLU

abracadabraPDF Forums PDF – Général Logo variable en fonction du choix dans liste déroulante (2) – RÉSOLU

  • Ce sujet est vide.
  • Créateur
    Sujet
  • #44697
    nabnub
    Membre

    Bonjour tout le monde,

    Je sollicite votre aide quant à un sujet qui à déja été traité sur le forum mais je n’ai pas vraiment compris la solution :
    http://abracadabrapdf.net/forum/index.php/topic,1107.msg4527.html#msg4527

    Je n’ai pas trop bien compris quelque type de bouton utilisé, puis comment leurs attaché un logo, dans mon cas une image.

    Je ne sais si quelqu’un veut bien me donner quelque explication au niveau du script ou bien serait il possible de posté un petit pdf avec quelques logo (images) qui changent selon la sélection faite
    par contre, je souhaiterai que la liste déroulante s’affiche à l’écran mais n’apparait pas à l’impression

    Merci bien.

Affichage de 9 réponses de 1 à 9 (sur un total de 9)
  • Auteur
    Réponses
  • #56158
    nabnub
    Membre

    Salut,

    Je ne sais pas si Alex est dans les parages, car c’est lui qui  a initialement donné la solution,

    ou bien Merlin, pouvez-vous svp me donner quelque pistes, j’ai vraiment besoin de trouver une solution

    merci

    #56159
    Merlin
    Maître des clés

    Je n’ai pas trop bien compris quelque type de bouton utilisé, puis comment leurs attaché un logo, dans mon cas une image.

    Il faut utiliser un champ de formulaire de type bouton, il n’y en a qu’un seul.
    Ensuite il faut importer une image comme icône du bouton, tu trouveras tous les détails de mise en œuvre dans l’Aide d’Acrobat.

    Je ne sais si quelqu’un veut bien me donner quelque explication au niveau du script ou bien serait il possible de posté un petit pdf avec quelques logo (images) qui changent selon la sélection faite
    par contre, je souhaiterai que la liste déroulante s’affiche à l’écran mais n’apparait pas à l’impression

    Prépare une maquette avec une liste déroulante et 5 boutons, et poste la en pièce jointe, on verra ce qu’on peut faire.

    :Smiley01:

    #56160
    nabnub
    Membre

    Salut Merlin et merci,

    je ne sais pas si j’ai bien saisi mais j’ai crée ce fichier test avec des images aléatoires de google

    http://cjoint.com/13nv/CKgqS0N8cgD.htm

    merci

    #56161
    Merlin
    Maître des clés

    Ton fichier est presque correct, il faut juste corriger une petite erreur : le « Bouton_0″ s’appelle en fait « Button_0″, c’est pour ça que ça ne fonctionne pas…
    :geek:

    #56162
    nabnub
    Membre

    tu veux dire au niveau du script?

    car j’ai fait le changement (  nom= »Button_ »+index;)  et rien ne se passe??

    au fait le script je l’ai placé dans le field Dropdown1 => format => Custom Keystroke Script

    est-ce le bon endroit?

    voila ce que j’ai écrit:

    Code:
    if(!event.willCommit)
    {
    //sur sélection d’un item
    nbreIcones=5;
    index=0;
    //on note position et dimensions du bouton Bouton_0
    rectangleBase=this.getField(« Bouton_0 »).rect;
    //On passe en revue tous les champs dont le nom commence par « Bouton_ »
      while(index  {
      nom= »Button_ »+index;
          if(index==event.changeEx)
          {
    //Si l’index est celui de la sélection, on rend visible et on positionne le bouton.
          this.getField(nom).hidden=false;
          this.getField(nom).rect=rectangleBase;
          }
          else
          {
    //On masque les autres.
          this.getField(nom).hidden=true;
          }
      index=index+1;
      }
    }

    est ce que j’ai loupé quelque chose au niveau des options des boutons?

    #56163
    Merlin
    Maître des clés

    tu veux dire au niveau du script?

    Surtout ne change rien au script.
    C’est le nom du bouton_0 qu’il faut corriger (==> Propriétés : Général).

    #56164
    nabnub
    Membre

    Merci beaucoup,
    ça marche

    parcontre j’ai remarqué que: association 1 ne renvoi rien

    et que le Bouton_5 n’est pas affiché

    est ce qu’il aurait un problem au niveau des valeurs d’export?

    http://cjoint.com/13nv/CKhlBw6MPHG_test_2.pdf

    #56165
    Merlin
    Maître des clés

    par-contre j’ai remarqué que: association 1 ne renvoi rien

    Si, ça fonctionne très bien, mais comme il n’y a pas d’image dans le bouton 0 rien ne s’affiche.

    et que le Bouton_5 n’est pas affiché

    Parce-qu’il manque le 6e intitulé !
    Voir ci-joint.

    :Smiley01:

    [attachment deleted by admin]

    #56166
    nabnub
    Membre

    c’est parfait maintenant

    un grand merci

Affichage de 9 réponses de 1 à 9 (sur un total de 9)
  • Vous devez être connecté pour répondre à ce sujet.